Willkommen in der Webstatt
User-1 am 14.01.07 21:46

Hallo,

Ich darf bekanntgeben, dass dieses Forum das erste ist, das ein neues Programm von einem Kollegen und mir unterstützt.
FFMS steht für Fast Forum Messaging System.
Der Name des Projekt ist COMC. Wir sind uns noch nicht einig was das letzte C bedeutet (evt. Client), aber COM steht für Community.
Nun, der sinn des ganzen ist, dass man ein Programm auf seinem Rechner starten kann, welches sich bei einem zentralen Server anmeldet. Das Programm schickt eine BoardId, euere Userid und ein Userkey (der ist NICHT euer Passwort) an den Server. Dieser kontaktiert das Forum und prüft die Daten. Stimmen diese, bekommt ihr ab diesem Zeitpunkt eine Meldung, wenn ein Ereigniss passiert, über das ihr Informiert werden wollt. Mögliche Ereignisse sind: Neuer Post, neuer Thread oder neue Pn.
Dabei wird das im Forum bereits vorhandene Favoritensystem benutzt. Wenn ihr also über einen Thread informiert werden wollt, fügt ihn zu den Favoriten zu. Da es allerdings oft vor kommt, dass man über ALLES im Forum will, wurde diese funktion explizit dazu gecodet. Man kann es im Profil=>Einstellungen aktivieren.
Im Profil findet ihr außerdem noch etwas anderes neues: Es werden FFMS Daten angezeigt. Euch bleiben 2 möglichkeiten, die Daten zu übernehmen: 'Händisch' übertragen oder einfach auf den Link klicken. Das (windows) Programm übernimmt die Daten automatisch.

ACHTUNG:
Alles befindet sich noch in der BETA Phase!
Da der Server im debug Modus läuft, kann es unter Umständen verhältnismäßig lange dauern, bis er Antwortet/einen Befehl ausführt.

Bitte meldet Fehler hier im Thread. Aber auch alle anderen Kommentare sind willkommen. Bei Fehlern schickt bitte die letzten paar Eintragungen im 'Status'-Fenster mit(windows client). Es zeigt die Raw-Datenübertragung.

Hier zum Download:
Windows Client (xyz-193)
Linux Client (xyz-161)

netcup.de Warum gibt es hier Werbung?
User-2 am 14.01.07 23:13

hm was ist die board id?

also was muss ich in welches feld eintragen?

User-3 am 14.01.07 23:14

Geh einfach hier ins Profil (Link oben im Header) und dann ist dort unten Links ein Link, den du anklicken kannst.

User-4 am 14.01.07 23:14

http://forum.webstatt.org/usercp.php unten links

User-5 am 15.01.07 13:23

Bei mir kommt immer nen Fehler wenn ich's von xyz-193 laden will!

User-2 am 15.01.07 13:31

und bei mir passiert nix ^^

User-5 am 15.01.07 13:42

mit Fehler mein ich nen 404

User-6 am 15.01.07 14:29

Quote
Bisher ist das ganze noch nicht ausgereift.
D.h. das ganze kann man nur neustarten, wenn man den Prozess killt und
neu startet.
Ausserdem muss das Ausgabeprogramm in der comc datei spezifiert werden.
Bisher ist es kdialog, es kann aber auch xmessage oder eigentlich jedes
andere programm verwendet werden. d.h. es kann auch, wenn man einen kleinen
jabber clienten schreibt über diesen versendet werden.
oder auch über einen irc bot in ein irc channel geschrieben werden.
Möglichkeiten für die Ausgabe hab ich im Ordner "bin" abgelegt
dabei sind xmessage und kdialog, sowie osd_cat, dass mit pos aufgerufen wird,
da dort die genauen daten spezifiert werden.

Das ist eigetnlich schon alles.


Ausgabeprogramm? oO
Und wer schreibt sich schon selber nen eigenen Jabberclienten (ausgenommen unser kleiner freak xyz-161)?!

User-1 am 15.01.07 14:32

Quote
Original von xyz-27
Bei mir kommt immer nen Fehler wenn ich's von xyz-193 laden will!
tatsache. aus irgend nem grund ist die datei nicht mehr auf dem server.
ich lad sie neu hoch, sobald ich daheim bin

User-7 am 15.01.07 14:51

Quote
Original von xyz-47
Ausgabeprogramm? oO
Und wer schreibt sich schon selber nen eigenen Jabberclienten (ausgenommen unser kleiner freak xyz-161)?!

du kannst dein Zeug auch in Python oder sonstwas schreiben.
ausserdem ist ein Jabberclient eine Simple sache....umfasst nur ein paar Zeilen, wenn man das jabber modul verwendet :D ich wollte aber ausser dem Socket modul keins verwenden, da ich keinen Bock hatte zu erklären wie man module installiert :D

osd_cat weiss ich nicht...wäre schön, wenn ich von denen, die es nicht draufhaben, es aber trotzdem funktioniert, die Anzeige rechts ein kleines ok zurück bekomme...reicht shcon per pm :D

will nur wissen, ob es mit der Datei getan ist, oder ob der noch ein paar libs braucht, die osd libs :D

(aber wenn amarok drauf ist, sollten die installiert sein ;))

User-6 am 15.01.07 14:55

Quote
Original von xyz-161
[quote]Original von xyz-47
Ausgabeprogramm? oO
Und wer schreibt sich schon selber nen eigenen Jabberclienten (ausgenommen unser kleiner freak xyz-161)?!

du kannst dein Zeug auch in Python oder sonstwas schreiben.
ausserdem ist ein Jabberclient eine Simple sache....umfasst nur ein paar Zeilen, wenn man das jabber modul verwendet :D ich wollte aber ausser dem Socket modul keins verwenden, da ich keinen Bock hatte zu erklären wie man module installiert :D

osd_cat weiss ich nicht...wäre schön, wenn ich von denen, die es nicht draufhaben, es aber trotzdem funktioniert, die Anzeige rechts ein kleines ok zurück bekomme...reicht shcon per pm :D

will nur wissen, ob es mit der Datei getan ist, oder ob der noch ein paar libs braucht, die osd libs :D

(aber wenn amarok drauf ist, sollten die installiert sein ;))[/quote]

Fr34k! =)

User-1 am 15.01.07 15:51

wieder oben

User-4 am 15.01.07 15:58

aber: dat Ding braucht auf alle Fälle noch ein brauchbareres Interface. Dieses Informationsfenster hat bitteschön eine Blasen- oder Wolkenform zu haben und das Programm selbst sollte z.B. in einer Tabelle die letzten 10 neuen Beiträge mit (Thread)Titel und Autor anzeigen, die sich via Mausklick im Browser anzeigen lassen.
Sehr sinnvoll (und ja auch nicht so schwer umzusetzen) wäre ein Anriss des hinzugefügten Textes (einfach befreit von BB Codes).

Munta!

xyz-14

User-1 am 15.01.07 16:00

bin nicht so der oberflächen coder, beschäftige mich lieber mit dem backend :D

User-4 am 15.01.07 16:13

jo, aber das funktioniert gerade auch nicht, mein Client empfängt keine Daten!

User-1 am 15.01.07 16:14

jo der server war kurz down. läuft aber wieder, musst neu verbinden

User-5 am 15.01.07 17:04

ich hatte vor paar tagen auch ne Idee sowas zu machen doch das hat sich wohl erledigt.

User-1 am 15.01.07 17:23

das konzept is schon über en jahr alt. nur hatte nie einer zeit

User-8 am 15.01.07 17:32

ääh kannst du das nochmal für Normaldumme erklären :D??
Also das Proggi starte ich auf meinem PC und stell dort ein über wellen Beitrag ich informiert werden will und der Server schickt dann einen Server-Push an mein PC wenn ein neuer Beitrag gekommen ist?

User-1 am 15.01.07 17:33

das forum schickt es an einen zentalen server. zu dem is dein client dauernd verbunden. und der leitet es an dich weiter

User-8 am 15.01.07 17:35

aight... danke!

User-9 am 15.01.07 17:41

also ich finde das teil geil, aber es tut sich noch nichts bei mir. Die oberfläche gehört noch verbessert!!!

User-1 am 15.01.07 17:42

ich verlier aus unerklärlichen gründen auch dauernd die verbindung...ich geh mal auf bugsuche

User-5 am 15.01.07 17:49

bei mir wird gar nicht angezeigt das es nen neues Thema gibt.

User-1 am 15.01.07 18:05

musst es ja erst aktivieren. entweder über die favoriten oder profil=>einstellungen=>"xyz-19achrichtigung für das ganze Forum"

User-7 am 15.01.07 19:03

oder das jeweilige forum in di eFavoriten aufnehmen :D

User-10 am 15.01.07 19:46

also bei mir kann ich die Einstellungen garnicht aufrufen da kommt immer nen fehler

User-7 am 15.01.07 19:47

beim windows programm? oder forums einstellungen?

User-10 am 15.01.07 19:58

windows programm, es wird angezeigt das ne datei fehlt.

User-1 am 15.01.07 21:27

unglaublich präziese fehlerbeschreibung

User-11 am 15.01.07 23:08

mhh...was mach ich falsch? muss nicht bei userkey der "wbb2_password-cookie-inhalt rein?

User-7 am 15.01.07 23:10

und die daten stimmen? prüf sie nochmal nach...

warum macht der eigentlich ein register und ein deregister? und wieder ein register....

komisch :D

User-11 am 15.01.07 23:11

ahhh geht schon ^^
danke ^^

User-10 am 16.01.07 14:31

@ snake:

User-12 am 16.01.07 15:15

funzt es eig bei jemanden auser snake schoN? ^^

User-2 am 16.01.07 15:48

ich hab noch nicht ganz verstanden was überhaupt passieren soll :D

User-13 am 16.01.07 15:52

Soweit ich weiß, wirst du in Echtzeit, ohne manuelle Aktualisierung der Programminhalt über neue Themen/Antworten in Forum xy durch einen Link in einer Bubble in Kenntnis gesetzt.

User-7 am 16.01.07 20:15

jop bei mir funzt es auch, die Linux versio halt :P

User-14 am 16.01.07 20:21

Wird für die xyz-19achrichtigung die Datenbank in bestimmten Zeitabständen abgefragt oder habt ihr es auf anderem Wege implementiert?

User-1 am 16.01.07 20:31

nein, ich bin kein freund von solchen sachen.

habs zwar schon mehrfach geschrieben, aber ich schreibs gerne nochmal:
das forum nimmt beim erstellen von ner pn/post/thread kontakt mit nem server auf (über nen einfachen socket (fsockopen())) und schickt diesem eine xml mit infos über das ereignis und den empfängern. der server leitet es dann weiter. der client hat eine dauernde verbindung zum server

User-14 am 16.01.07 20:34

Quote
habs zwar schon mehrfach geschrieben, aber ich schreibs gerne nochmal:


xyz-48ke, ich habe nur die letzte Seite gelesen.

User-3 am 19.01.07 01:07

Quote
Original von xyz-141el
Wird für die xyz-19achrichtigung die Datenbank in bestimmten Zeitabständen abgefragt oder habt ihr es auf anderem Wege implementiert?


Wäre eigentlich eine ziemlich große Ressourcenverschwendung und dann könnte unser kleines Projekt nicht in Echtzeit arbeiten, da der Server dann z.B. nur 20 Foren in der Sekunde abfragen könnte und so geschieht die Übermittlung der xyz-19achrichtigung direkt in Echtzeit...

Was das Forum betrifft ist es eigentlich im Prinzip recht simpel. Wenn ein User sich anmeldet wird das Forum vom Server kontaktiert und der User wird als online aufgenommen und die User, die atm. online sind, erhalten einfach eine xyz-19achrichtigung, wenn die Favoriten das vorsehen. (bzw. wenn man in den Einstellungen das ganze Forum aktiviert hat)

User-13 am 28.01.07 16:06

xyz-48ke xyz-193, dass du es so schnell wieder on gestellt hast. ;D

Run-time error '339':

....

User-7 am 28.01.07 16:11

und dass ich snake so schnell bescheid gesagt hab, sonst hätte der gute snake das garnicht gemerkt :D

User-15 am 28.01.07 19:07

Hey xyz-193..

Gute Idee, werd ich nutzen wenn die Beta ausgereift ist :)

User-4 am 30.01.07 09:08

Hi xyz-193!

Sachens mal, wie sieht denn die Entwicklung bei euch aus? Ich habe meinen Alternativclient mittlerweile fertig und warte voller Ungeduld auf die Ausbügelung der letzten Unstimmigkeiten des Servers:


    [*]Warum bekomme ich manchmal kein "register ok" oder erst nach mehreren Versuchen?
    [*]Warum bekomme ich seit einem Tag alle Nachrichten doppelt?


Gehe ich recht in der Annahme, dass du das Ganze momentan ersteinmal auf die Warteliste gesetzt hast


lG

brb
User-1 am 30.01.07 15:53

hi,

jeder befehl wird in eine wartschlange gesteckt. der register befehl, wird, nachdem er von der ersten schlange befreit wurde, bearbeitet in eine andere gesteckt, welche beim bearbeiten den http anspricht. d.h wenn ein http mal bischen länger braucht, kann es paar sec gehen, bis er auf den register befehl antwortet.

das mit dem mehrfach senden ist mE ein problem im board addon. das bestimmt an welchen client welche nachrichten gehen. der server hat nur ne vermittelnde rolle.
wenn das problem nochmal auftritt, versuch mal 'unregister BOARDID' und dann en neues register, was dann passiert.

kann ich dein client mal sehen?

User-16 am 30.01.07 16:02

339:

Component 'MSCOMCTL.OCX' or one of its dependencies is not registered: a file is missing or invalid.
:D

User-13 am 30.01.07 16:08

such bei google danach und lad es in deinen Systemordner... Die Lib fehlte bei mir auch.

oder hier

User-4 am 30.01.07 16:17

jo, kannst mal nen Blick drauf werfen, es gibt aber noch ein paar Bugs, wenn Beispielsweise mehrere Nachrichten pro Sekunde eintrudeln kommt es zu Darstellungesfehlern im ListView Element, das muss ich noch ausbügeln.

Ansonsten bin ich dankbar für Hinweise auf alles, was irgendwie noch nicht geht oder so. lG

brb

User-13 am 30.01.07 16:26

Hab gerade mal das von xyz-14 laufen. Sieht sau geil aus ... nun muss nur noch jemand posten :D

edit://

NUN FUNZT ES. Also bei dem PS Brushes Post von xyz-179 hat er mir die Bubble anzeigt

User-1 am 30.01.07 17:13

gefällt mir.

aber eins:

ich klick auf "alle einträge aus der registry löschen", les die meldung und klick dann auf [nein]. dennoch ist mein gespeichertes board weg

//noch 2 sachen:
-man kann boards nicht editieren (hab mich eben vertippt und musste alles nochmal neu machen

-nachdem man en neues board hat oder eins gelöscht wurd, muss man die verbindung neu aufbauen, dass er den register befehl raus kloppt

//edit2:

komisch, serverlog:[17:14:09] (RegThread) open: http://forum.webstatt.org/.....
[17:14:15] (RegThread) timeout!

User-4 am 30.01.07 17:20

ah, gut das du es sagst, ich habe den deregister- Befehl noch nicht reingehauen. Man muss immer neu Verbinden, hast recht! Wird geändert

Das mit dem Bearbeiten stimmt, war zu faul.

Die Board- Daten werden nicht in der Registry gespeichert sondern im Programmordner.



Was hat das Serverlog zu bedeuten? Ich muss gestehen, dass dein Server von mir alle 20 Sekunden ein neues "register xxx xxx xxx" bekommt, wenn er bis dahin noch nicht auf das vorherige geantwortet hat, hoffe, das ist in Ordnung.

lG

brb

User-1 am 30.01.07 17:22

naja der server erkennt beim verbinden mit dem webstatt http (der ja auch mir gehört) en fehler. warum weis ich nicht...

User-4 am 30.01.07 17:23

komisch. funktioniert aber trotzdem, ich freu mich *g

User-1 am 30.01.07 17:23

jo es geht ja. nur nicht jedes mal. sieht man ja, nach 3 versuchen gehts :D

User-1 am 30.01.07 17:37

der server macht jetzt meldung wenns in die hose gieng.

User-4 am 30.01.07 17:38

bestens

User-1 am 30.01.07 17:43

sag mal, hast du den ton vom handy aufgenommen? man vernimmt leichtes knistern im hintergrund

User-4 am 30.01.07 17:45

ne, der ist von http://www.findsounds.com/ - aber wahrscheinlich ähnlich entstanden.

zu nervig? ach, egal, kann man ja ausstellen oder händisch austauschen (datei ersetzen)

User-1 am 30.01.07 17:45

der ton is gut, das knistern nervt nur

User-16 am 30.01.07 18:15

Wenn ein so kleines Tool in der Registry rumfuschen würde, dann wundert mich gar nichts mehr. :D

User-4 am 30.01.07 18:23

Quote
Original von xyz-58
Wenn ein so kleines Tool in der Registry rumfuschen würde, dann wundert mich gar nichts mehr. :D


verstehe ich nicht. Natürlich tut es das, alle anderen Optionen werden in der Registry abgespeichert (darum gibt es ja die Möglichkeit, alle Einträge zu entfernen).
Nur die Boards werden in einer Textdatei gespeichert.


xyz-193: Wäre es möglich, dass der Server bei internen Fehlern oder abgelehnten Registrierungen ("register fail") die BoardID zurückgibt, auf die sich der Fehler bezieht? Würde die verarbeitung mehrerer Boards erleichtern.

User-16 am 30.01.07 19:02

Halt ich nicht viel von, prinzipiell. So kleine Spielereien können auch gut über andere Mittel realisiert werden.

Wenn das alle so machen, staut sich der Anteil der verfuschten Einträge und das nennt sich dann Datenmüll. :D

User-4 am 30.01.07 19:09

Nö, sehe ich anders, gerade für sowas gibt es "[HCU] - Software" ja. Die Registry ist für Optionen einfach optimal, weil sie das Fehlerpotenzial auf ein Minimum reduziert.
Außerdem gibt es ja extra die Möglichkeit, alle Spuren in der Reg bequem zu löschen.

Ich weiß auch nicht, warum "große" Projekte sich der Registry eher bedienen sollten als "kleine Spielereien", die kleinen Spielereien sind doch viel eher darauf angewiesen (von wegen Zeit und so).

naja, whatever.

brb

User-16 am 30.01.07 19:12

Naja, ich find es auch nicht gut, wenn eine Software mal just 1500 neue Einträge anlegt... Aber warum ist es schlechter, wenn man die Daten zum Programmstart aus einer Ini, o.ä. ausliest? Dazu kann man sich ja einmal eine Class schreiben, die dann getestet und immer wieder dazu benutzt wird.

Aber das ist vllt. auch einfach eine grundsätzliche Einstellungssache...

User-1 am 30.01.07 19:20

also ich speicher immer sehr gerne in xml dateien :)

User-4 am 31.01.07 18:14

sachensma dr. snake, giwwet ansinnen, dat ganze aufs phpbb auszudehnen?

User-1 am 31.01.07 18:30

jo hab lib die im großen und ganzen "plattformunabhänig" ist, die man in verschiedene forensysteme einbauen kann. nur kenn ich mich mit dem phpbb nicht aus...

User-4 am 31.01.07 18:33

wie tief greifst du denn in das System ein? Wahrscheinlich musst du UserID, Usernamen und Passwort aus der DB auslesen?
Wenn du Bock hast, kannst du mir ja via PM schreiben, auf welchem Port dein Server auf Forenbenachrichtungen lauscht und wie die XML- Datei aufgebaut ist, die gesendet wird.

User-16 am 31.01.07 18:36

Wollt ihr nun eigentlich was konstruktives machen, oder will einer was entwickeln und einer Sherlock Holmes spielen? :D

User-1 am 31.01.07 18:44

hm?
das protokoll hat er erkunded wärend ich nicht da war. und meine php lib hab ich ihm eben geschickt ;)

User-4 am 31.01.07 18:45

danke dafür, werde sie mir gleich mal ansehen

User-1 am 31.01.07 19:03

wennde mir die url sagst, adde ichs im server und geb dir en boardkey

User-4 am 31.01.07 19:10

http://lathen.xn--ngel-5qa.de/forum/

hm, muss mir noch ne Möglichkeit ausdenken, dass der Server auf das Board zugreifen kann, immerhin ist das htaccess geschützt. Ich werde mal schauen

User-1 am 31.01.07 20:13

der XXX nennt sich übrigends xyz-209 :)

User-4 am 01.02.07 04:24

So, FFMS² 1.0.153, paar neue Funktionen wg. Verbindung, Autostartregistrierung im System und 'n paar Kleinigkeiten.

Wäre nett, wenn ein paar Leute testen würden, ob die Sprechblasen korrekt angezeigt werden, damit scheint es noch Probleme zu geben?!?!?!

User-14 am 01.02.07 08:17

Servus,

ich habe es mal heruntergeladen und alles registriert, allerdings sagt es mir plötzlich:

Quote
Meldung: Verbindung wurde aufgrund einer Zeitüberschreitung oder eines anderen Fehlers getrennt (9)


Und bei einem neuen Connect:

Quote
Meldung: Herstellen der Verbindung wird absichtlich verweigert (9)


// edit

Wenn ich das Programm erneut starte klappt die Verbindung wieder, bricht nach kurzer Zeit aber wieder ab. Ich glaube wenn ich einen Beitrag schreibe.

// edit2

Hat wohl doch nichts mit neuen Beiträgen zu tun. Nach ein paar Sekunden wird meine Verbindung getrennt.

User-4 am 01.02.07 14:51

hm, merkwürdig, einen Timeout hatte ich noch nie. "Verbindung wurde absichtlich getrennt" habe ich auch manchmal, gehe davon aus, dass es mit dem Server zusammenhängt. Ich kann mir aber nicht erklären, was genau da passiert?

Kann es vll. etwas mit deinen Portfreigaben / Weiterleitungen zu schaffen haben? Momentan benutze ich nämlich Zufallsports aus einem gewissen Bereich, von denen Winsock die Verbindung zum Serverport aufbaut. Der jeweils benutzte Port wird am Anfang jeder Sitzung - bei der Einwahl - im Log angezeigt....

lG

brb

User-14 am 01.02.07 15:17

Hi,

ich bin gerade an der Uni und kann daher nicht schauen. Aber da ich einen Router benutze, gehe ich davon aus, dass manche Ports geblockt sind.
Allerdings sollte ein einmal akzeptierter Port ja nicht nachträglich gesperrt werden, oder? Die anfängliche Verbindung wird einwandfrei aufgebaut.

User-1 am 02.02.07 18:08

hab glaub das problem mit dem timeout gefunden: allem anschein nach war es der dns des providers.
hab nun den primären dns einfach auf meinen eigenen server gelenkt, auf dem bind läuft. bis jetzt scheints perfekt zu funktionieren

User-1 am 02.02.07 21:48

Nungut, ich denke die 1. phase des beta tests dürfte so gut wie abgeschlossen sein.
einige fehler im server beseitigt, und dank barabbas jetzt auch ein stabiles frontend.

hat jemand interesse, den beta test in soweit zu unterstützen, dass er sein forum ins netzwerk legt?

User-14 am 02.02.07 21:56

Ich habe kein Forum, würde aber die neue Version installieren ;)

User-17 am 02.02.07 23:22

mach mal einer ne seite auf, wo er die vorzüge von dem dingens mal so richtig darstellt und so. sowas hilft meisstens unterstützer zu finden. für welche foren funktioniert der spass denn schon?

User-1 am 02.02.07 23:24

jo will ich, bin aber noch nicht dazu gekommen

User-18 am 04.02.07 12:00

Hi,

ich hab ma ganz frech ein kleines AppleScript geschrieben, welches als Programm in die comc-Perldatei eingetragen werden kann, um die Ausgabe an Growl weiterzuleiten.

So schön könnte das dann aussehen :)

Einfach in die Perldatei als $extProgramm osascript bin/comc.scpt <title> <message> eintragen. Die comc.scpt muss dann natürlich auch ins bin Verzeichnis gelegt werden.

User-4 am 05.02.07 13:36

So, wieder eine neue Version, diesmal wieder mit Winsock, da es mit CSocket Probleme gab, die ich zu diesem Zeitpunkt nicht beheben kann.
Ansonsten alles beim Alten, Rückmeldungen wg. Fehlern auf Grund des Winsock Controls bitte an mich (hier, Mail, ICQ)

xyz-48ke

brb

User-16 am 05.02.07 14:16

Darf ich mal fragen, in welcher Sprache die Programme geschrieben wurden?

User-4 am 05.02.07 14:19

Mein Client ist VB6. Da du ja aber sicher gleich den großen Fachmann hier rauslassen wirst, wunder mich etwas, dass du *das* nichtmal selbst in Erfahrung bringen kannst :P

User-16 am 05.02.07 14:20

Wieso Fachmann? Ich kenn mich allerhöchstens mit Delphi / Pascal aus. :D


Falls du das letztens falsch verstanden hast: Das war nicht böse gemeint, ich war bloß verwundert. Fall das allerdings nit ernst gemeint war, will ich nichts gesagt haben. ;)

User-4 am 05.02.07 14:21

passt scho. *beep beep*

nein, es ist wirklich alles in Ordnung, keine Panik. Hatte dich etwas diskussionsfreudiger eingestuft *g

User-16 am 05.02.07 14:22

Das interessiert mich nun doch. Hab ich mich irgendwie unbewusst um Ton vergriffen? *nachlesen geht* :O

User-13 am 05.02.07 14:23

Ich glaube es geht um die Sache mit der Registry ?! ^^

Damit es nicht zu sehr OT ist:

Das neue Programm funzt wieder, dass alte hat irgendwie nichts angezeigt. Wieso ist da jetzt wieder nur ein Bubblestyle zur auswahl ?

User-19 am 05.02.07 14:23

@Dust: bitte über PM? Ich glaub der Thread is dafür zu schade um das zu klären! ;)

User-4 am 05.02.07 18:21

So, weil ich auf Dauer nicht alles hier mit neuen Versionsmeldungen vollkleistern will, die ja höchstens eine Handvoll Leute hier interessieren, habe ich einen Updatehinweis eingebaut.

Also einfach diese Version laden, falls es dann etwas neues gibt, werdet ihr darauf im Programm hingewiesen.

lG

brb



==> http://xn--ngel-5qa.de/ffms2.zip

User-14 am 05.02.07 19:24

Super. xyz-48keschön.

User-8 am 05.02.07 20:10

Ich weiss nicht obs an mir liegt aber bei mir kommt immer diese Meldung (also wen ich das neue da starte)

Aktueller Status: Der Remote-Host-Name wird in eine IP-Adresse umgewandelt(4)
Meldung: Verbunden über Port xxxx
Meldung: <--- version FFMS² by xyz-14 1.2 Build 175
Meldung: <--- register xxxx xxxxxxxxxxxxxxxxxxxxxxxx:
Meldung: Ihre derzeitige Version ist aktuell
Meldung: ---> You have the cliendid x
Meldung: <--- register xxxxx xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx: - TIMER
[COLOR=red]Meldung: Connection is aborted due to timeout or other failure (9)[/COLOR]

was muss ich tun?

User-4 am 05.02.07 20:29

hm, kannst du mir eine genauere Beschreibung geben? Nach welcher Zeit genau erscheint die Meldung? Immer? Nutzt du DSL?

lG

dsn

User-8 am 05.02.07 21:47

DSL hab ich ja... (Verbindung über PC->Router->Internet falls das was ausmacht wegen Ports und so?)

Es erscheinen immer die oberen Meldungen wenn ich mich Verbinde und dann nach so ca. 4-5 Sekunden dann die Letzte (rote)... und bis jetzt kamen sie immer, also ich habs noch nie geschafft eine Meldung zu erhalten

// aja und wenn ich Status anzeigen klicke kommt das:
Aktueller Status: Der Socket ist geschlossen(0)

User-4 am 06.02.07 00:13

hm, ich habe kein DSL, kann dazu aber nur sagen, dass sich FFMS² mit Zufallsport aus einem gewissen Bereich verbindet. D.h. der Serverport ist immer x, der lokale Port aber zwischen 500 und 1500. Keine Ahnung, ob das eine Bedeutung für den Router hat. Merkwürdig ist, das die Verbindung offensichtlich aufgebaut wird und dann abbricht - grundsätzlich glaube ich ja immer gerne, dass ich irgendeinen Fehler gemacht habe, aber in diesem Fall weiß ich einfach nicht, welcher es sein könnte - die Winsock- Verbindung steht ja und es ist eigentlich nichts erforderlich, um diese Aufrecht zu erhalten solange Server und Client online sind.

Vll. weiß xyz-193 dazu etwas, ich habe gerade mal keine Idee

lG

xyz-14

User-1 am 06.02.07 13:34

warum definierst du denn einen lokalen port?
würde das lieber vom os zuweisen lassen, dann ist sicher, dass der port nicht schon belegt ist

User-1 am 11.02.07 18:33

ich hab einmal alles auf http://www.comc.de zusammengefasst und hoffe auf ein feedback

User-17 am 11.02.07 19:07

schaut aus, als brächtest du dafür sowas wie ein design oder so...

User-6 am 11.02.07 20:23

Quote
Original von xyz-70
schaut aus, als brächtest du dafür sowas wie ein design oder so...


Schonmal Designs (wenn man es so nennen kann) von Assemblerfreaks gesehn? Da kriegste Augenkrebs!

Ich versteh jetzt zwar, was der Sinn des Scripts ist und so, aber die Funktionsweise ist mir noch immer schleierhaft. :tired:

User-8 am 13.02.07 13:49

ich weiss jetzt wieso es bei mir nicht gieng... :/ es ist nämlich so das ich auf den Link im Profil geklickt habe und dort werden bei mir andere Daten ins Programm eingetragen als wenn ichs von Hand mache. Nun ist von Hand eingetragen und läuft ohne diese Fehlermeldung...

Creative Commons Lizenzvertrag
Alle Inhalte des Webstatt-Archivs stehen unter einer Creative Commons Namensnennung - Weitergabe unter gleichen Bedingungen 3.0 Unported Lizenz.

Impressum & Kontakt